Friendly Metal Detecting Forums   Myers Depot Metal Detectors
List all sponsors

Go Back   Friendly Metal Detecting Forums > Detectors and Gear > All About Detectors

Reply
  
Thread Tools Display Modes
  #1  
Old 09-10-2012, 04:08 PM
aflippincan! aflippincan! is offline
Junior Member
 
Join Date: Feb 2012
Posts: 61
Default f2 ISSUES

Have loved the f2 but its giving me fits. Here we go.
Very chatty even with sensativity down. Cant get clean signals, very scratchy.
Seems to be off on pinpointing. VDI not accurate. And most of all I am getting no depth. Two inches is about it. Hitting great spots but frusterated with lack of depth. Any suggestions other than sending it in to Fisher? Thanks.
Reply With Quote


  #2  
Old 09-10-2012, 04:13 PM
detectingMO's Avatar
detectingMO detectingMO is offline
Supporter
 
Join Date: Jun 2012
Location: Columbia, MO
Posts: 3,228
Default

loose coil connection? dirt between coil and coil cover? Low or incorrect batteries? Those are the common causes besides bad coil or something out of balance with the detector.

__________________
| ShowMeTreasure.com
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

http://youtube.showmetreasure.com |

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
discount code A1466 | https://
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
https://twitter.com/ShowMe_Treasure

Reply With Quote


  #3  
Old 09-10-2012, 04:23 PM
DIGGER27's Avatar
DIGGER27 DIGGER27 is offline
Elite Member
 
Join Date: Feb 2010
Location: Alabama, by way of Detroit, Tampa Bay, Alabama and Kansas
Posts: 15,182
Default

Did it always work this way, or it just started?
Did you get a multiple coil package and did you try another coil?

Sounds like a bad coil or coil wire problem to me.

__________________
If attacked by a pack of clowns...go for the juggler! "

Reply With Quote


  #4  
Old 09-10-2012, 05:34 PM
aflippincan! aflippincan! is offline
Junior Member
 
Join Date: Feb 2012
Posts: 61
Default f2

Ive loved this machine up untill about two weeks ago. Ive tried both coils, tightened the cable, tried to clear any dirt from connectors, and changed batteries. Did a test on a silver dime in the backyard buried at 6 or 7 inches and got nothing with sensativity turned all the way up. Its just bizzarre. Get a somewhat repeatable signal, dig and get nothing. False signals used to never happen. Or I get a 82 on the VDI, and dig up a nail or pulltab. This used to never happen either. WHY WHY WHY WHY!
Reply With Quote


  #5  
Old 09-10-2012, 05:53 PM
flyin-lowe's Avatar
flyin-lowe flyin-lowe is offline
Elite Member
 
Join Date: Dec 2011
Location: Henry County, IN
Posts: 781
Default

If you have checked the connections, changed the batteries, and experience the same problems with both coils, I would send it in to Fisher, assuming you were the original owner.

__________________
Fisher F2, Garrett AT Pro, Garrett Pro Pointer, Lesche Digger. Oldest coins 1831 Capped Bust dime (1st silver ever dug) and 1876 Seated dime.

Reply With Quote


  #6  
Old 09-11-2012, 12:42 PM
DIGGER27's Avatar
DIGGER27 DIGGER27 is offline
Elite Member
 
Join Date: Feb 2010
Location: Alabama, by way of Detroit, Tampa Bay, Alabama and Kansas
Posts: 15,182
Default

Turn it on and keep your finger on the power button as it powers up for about 10 seconds.
It might beep to let you know it's done.
This is a factory reset and it could work...hopefully.

__________________
If attacked by a pack of clowns...go for the juggler! "

Reply With Quote


  #7  
Old 09-11-2012, 03:25 PM
aflippincan! aflippincan! is offline
Junior Member
 
Join Date: Feb 2012
Posts: 61
Default

Cool, I'll try it out. Thanks from a fellow Kansan by way of Holton.
Reply With Quote


  #8  
Old 09-11-2012, 03:30 PM
slag's Avatar
slag slag is offline
Elite Member
 
Join Date: Aug 2012
Location: NE Kansas
Posts: 749
Default

Originally Posted by aflippincan! View post
Cool, I'll try it out. Thanks from a fellow Kansan by way of Holton.
Have you detected Banner Creek Reservoir yet? Popular swim place...
Reply With Quote


  #9  
Old 09-11-2012, 03:35 PM
aflippincan! aflippincan! is offline
Junior Member
 
Join Date: Feb 2012
Posts: 61
Default

I have not. Havent been able to get up there to put in some good hunting time. Only hit up the highschool and a few old houses. I'm kicking myself for not hitting up an old curb tearout near downtown over memorial day. What was I thinking.
Reply With Quote


  #10  
Old 09-11-2012, 03:53 PM
bruinvikes's Avatar
bruinvikes bruinvikes is offline
Elite Member
 
Join Date: Dec 2011
Location: Curtice, Ohio
Posts: 6,231
Default

Originally Posted by DIGGER27 View post
Turn it on and keep your finger on the power button as it powers up for about 10 seconds.
It might beep to let you know it's done.
This is a factory reset and it could work...hopefully.
That is exactly what I was going to suggest. I learned that reset trick from Patton a few months ago.

__________________
Fisher F70, Fisher F44, Fisher F2, 2020 clad: $0.73, Silver coins: 0, Indian heads: 0, Wheaties: 1, Gold rings: 0, Silver rings: 0, Total clad: $287.53 (after paying off the F2), Silver coins: 38, Gold rings: 4

Reply With Quote


  #11  
Old 09-11-2012, 03:56 PM
Curbdog's Avatar
Curbdog Curbdog is offline
Elite Member
 
Join Date: Dec 2010
Location: Middle TN
Posts: 3,055
Default

I remember my F2 was very, very, sensitive to any EMI. Also since you cannot ground balance it, mineralized soil would make it chatty and also kill the depth of it.

Maybe it's the outside conditions that are making your F2 act up.

__________________
Makro Kruzer, Nokta Anfibio Multi

Reply With Quote


  #12  
Old 09-11-2012, 05:08 PM
slag's Avatar
slag slag is offline
Elite Member
 
Join Date: Aug 2012
Location: NE Kansas
Posts: 749
Default

Originally Posted by aflippincan! View post
I have not. Havent been able to get up there to put in some good hunting time. Only hit up the highschool and a few old houses. I'm kicking myself for not hitting up an old curb tearout near downtown over memorial day. What was I thinking.
It's been awhile since I attended high school there (early to mid 90's). I graduated before they built the gym addon. Has the front of the school changed any?
Reply With Quote


  #13  
Old 09-11-2012, 05:50 PM
borborygmus's Avatar
borborygmus borborygmus is offline
Elite Member
 
Join Date: Jul 2012
Location: SF Bay Area
Posts: 508
Default

2nd the EMI issue, which subsided once i left the area. then again, i went to an area that gave me no signals - that was very strange.

__________________
F2 ׀ SS - total intake: cups of coffee (0); donuts (0)

Reply With Quote


  #14  
Old 09-13-2012, 03:19 PM
aflippincan! aflippincan! is offline
Junior Member
 
Join Date: Feb 2012
Posts: 61
Default

Did the reset method. Seems to have helped. Unit did not make a noise indicating a reset was done though. Much less chatter and got some target at 3 to 4 inches. Thanks everyone.
Reply With Quote


  #15  
Old 09-13-2012, 07:56 PM
TexasPinpointer's Avatar
TexasPinpointer TexasPinpointer is offline
Senior Member
 
Join Date: Mar 2012
Location: Lake Dallas, Texas via Brooklyn,NewYork
Posts: 489
Default

I had those issues when I received my F2 at day one. Sent it to Fisher and they replaced the contact terminals and the entire face plate assembly. No issues since.I would call up Fisher. Good luck,and let us know how it turns out.

__________________
Fisher F2,F5.Tesoro Compadre.Garrett PP.Custom Buzz WilsonBomb2Lesche Digger. Started 03/2012. YTD clad$42.79.SterlingSilverUSAF ring,1.35oz.925 Bracelet,Rosies:3,Wheats:6

Reply With Quote


Reply


Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctx issues HullGuitars Beach and Water Hunting 40 05-14-2013 03:46 AM
AT Pro issues??? ebone581 All About Detectors 11 11-18-2012 03:57 PM
at pro issues TristateJ How to Use Your Metal Detector 4 10-12-2011 10:07 AM
New Ace 350 and having issues. HELP! Tab-Star How to Use Your Metal Detector 15 09-21-2011 06:53 PM
Possible issues with AT PRO nativetexan How to Use Your Metal Detector 25 04-15-2011 01:05 AM


All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.